Realize Login Issue
Incident Report for Savvas System Health
Resolved
This incident has been resolved.
Posted Apr 19, 2024 - 14:46 EDT
Investigating
Some users might be experiencing slowness when logging into Realize. Our team is actively troubleshooting the issue and we will post updates here as soon as possible.
Posted Apr 19, 2024 - 10:39 EDT
This incident affected: Realize, Realize Reader, and Realize Reports.