Realize Reader Access (Minor Issue)
Incident Report for Savvas System Health
Resolved
This incident has been resolved.
Posted Jan 20, 2022 - 17:23 EST
Update
This issue has been resolved.
Posted Jan 11, 2022 - 10:39 EST
Update
Teams have isolated the cause of impacted access to Realize Reader titles and are verifying the solution with affected parties.
Posted Jan 10, 2022 - 15:31 EST
Investigating
Some customers may be unable to access certain Realize Reader titles. We are actively working to resolve this issue and will provide updates as they become available.
Posted Jan 07, 2022 - 16:07 EST
This incident affected: Realize Reader.