Realize is not accessible
Incident Report for Savvas System Health
Resolved
This incident has been resolved and service is fully restored. The root cause was a global internet issue with Akamai, our content delivery network provider. This incident impacted many web sites across the globe, including Realize.
Posted Jul 22, 2021 - 13:12 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 22, 2021 - 12:47 EDT
Identified
It has been identified that Savvas platforms and websites are part of a larger internet outage affecting much of the United States. Our teams are monitoring this fluid situation and will update you accordingly.
Posted Jul 22, 2021 - 12:24 EDT
Investigating
Our engineering team is investigating this issue and will work to restore access as soon as possible. Updates will be forthcoming.
Posted Jul 22, 2021 - 12:01 EDT
This incident affected: Realize, Realize Reader, Realize Reports, and EasyBridge.