Realize performance issue

Incident Report for Savvas System Health

Resolved

This issue is resolved.
Posted May 08, 2025 - 09:57 EDT

Monitoring

Our team is actively monitoring and maintaining Realize system health while we work in parallel to implement a permanent fix for the issue that impacted page loading earlier today.
Posted May 07, 2025 - 17:55 EDT

Investigating

We are investigating an issue reported by some users that the Classes page and other pages in Realize are not loading properly. We are reviewing this and will will share updates as soon as possible.
Posted May 07, 2025 - 09:42 EDT
This incident affected: Realize.