Savvas Realize Assignment Loading Issue

Incident Report for Savvas System Health

Resolved

Our team has corrected the issue.
Posted Sep 25, 2026 - 15:32 EDT

Investigating

Our team is investigating an issue that may intermittently prevent users from accessing assignments. We are investigating this and will provide updates as available. If users encounter any issues, we recommend performing a cache clear to resolve the issue. This can be done by clicking Ctrl + Shift + R (Windows/Linux) or Cmd + Shift + R (Mac) on the affected page.
Posted Sep 25, 2026 - 13:29 EDT
This incident affected: Realize.