Intermittent Content Issues

Incident Report for Savvas System Health

Resolved

This incident has been resolved.
Posted Nov 15, 2023 - 16:07 EST

Investigating

Our development team has observed some intermittent issues with content loading inside Savvas Realize.

Customers may sometimes experience issues with playing videos to completion, or completing downloads for some content types.

Teams are actively working to resolve this issue. We apologize for the inconvenience.
Posted Nov 14, 2023 - 13:36 EST
This incident affected: Realize.