Realize SSL Certification Issue
Incident Report for Savvas System Health
Resolved
Our team continues to work directly with the limited amount of customers experiencing this issue. If you need assistance please contact us directly.
Posted Sep 30, 2021 - 17:28 EDT
Investigating
A change was made by Let's Encrypt, an organization that issues SSL certifications that Realize uses. The change took place months ago, but today we are seeing that certain networks/browsers are still using old trust stores which are now no longer valid, as the intermediate cert that was retired over 6 months just expired. This change is impacting some customers who are working from behind district implemented web filters. We are working to remedy the situation and will provide updates here.
Posted Sep 30, 2021 - 14:02 EDT
This incident affected: Realize.