Savvas Realize Performance Issue
Incident Report for Savvas System Health
Resolved
We have resolved the issue.
Posted Nov 12, 2024 - 15:29 EST
Investigating
Realize is currently experiencing performance issues and slowness in response times. Our team is investigating this issue and will correct as soon as possible.
Posted Nov 12, 2024 - 14:36 EST
This incident affected: Realize.