Update: Our web service provider is experiencing an issue which is impacting Savvas Realize as well as many sites across the Web. We are working directly with them to restore our services as quickly as possible. Users might see slow performance or non-responsive pages in Realize under Browse and Search until this issue is resolved.
Posted Sep 26, 2024 - 15:21 EDT
Investigating
Some customers may experience slowness or incomplete page loads when accessing Realize content. Our team is investigating the issue and will work to resolve as quickly as possible.