Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 25, 2025 - 20:00 EDT
Scheduled
SuccessMaker is undergoing the annual Back to School 2025 system upgrade, which is scheduled from July 25th, 8PM ET to July 28th, 12AM ET. Customers may experience up to 40 minutes of downtime as a result of this update. In addition, reporting features may not be functional during the upgrade window.
Posted Jul 25, 2025 - 17:09 EDT
This scheduled maintenance affected: SuccessMaker.