Savvas Realize Performance Issue

Incident Report for Savvas System Health

Resolved

This incident is resolved. Savvas Realize is fully operational.
Posted Jun 03, 2025 - 19:01 EDT

Investigating

Our team is working to resolve a technical issue that is impacting users' ability to access Realize. We will restore service as soon as possible.
Posted Jun 03, 2025 - 18:27 EDT
This incident affected: Realize.