Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 24, 2025 - 22:30 EST
Scheduled
We will be performing planned maintenance starting at 10:30PM EST on 01/24/25 until 8AM EST on 01/25/25. During this time, intermittent issues for Realize, Realize Reader, Realize Reports, EasyBridge, and SuccessMaker could occur. We apologize for any inconvenience this may cause and will update status.savvas.com when maintenance is complete.
Posted Jan 23, 2025 - 10:46 EST
This scheduled maintenance affected: Realize, Realize Reader, Realize Reports, EasyBridge, and SuccessMaker.