Outlier Services

Incident Report for Savvas System Health

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 12:15 EST

Investigating

Due to a partner outage, students are experiencing an elevated error rate when working through assignments. There are some instances when a student may not be able to get to the course.
Posted Nov 18, 2025 - 09:09 EST
This incident affected: Outlier.org.