Realize Administrator Reports - Processing Delays
Incident Report for Savvas System Health
Resolved
This incident has been resolved.
Posted Sep 06, 2023 - 11:16 EDT
Identified
Realize Reports is experiencing data processing delays that may impact data in reports 9/1/23 and later. The team has identified the issue and is working on a fix.
Posted Sep 05, 2023 - 11:59 EDT
This incident affected: Realize Reports.