Savvas Realize Content Loading Issue
Incident Report for Savvas System Health
Resolved
This issue is resolved.
Posted Nov 11, 2024 - 11:43 EST
Investigating
Realize is not loading content and functionality properly for some users. Our team is actively investigating the issue.
Posted Nov 11, 2024 - 10:09 EST
This incident affected: Realize.