Intermittent issues in Realize

Incident Report for Savvas System Health

Resolved

This issue has been resolved.
Posted Jun 08, 2026 - 09:46 EDT

Investigating

Users may be experiencing intermittent issues in Realize. Our teams are actively investigating the issue.
Posted Jun 08, 2026 - 08:50 EDT
This incident affected: Realize, Realize Reader, and EasyBridge.