User Creation & Modification - Processing Delays
Incident Report for Savvas System Health
Resolved
This incident has been resolved.
Posted Jul 25, 2024 - 18:56 EDT
Investigating
Our team is receiving reports of latency when creating or modifying user accounts in the rostering process. We are actively working the issue. No data has been lost. If you encounter an error, please wait 24 hours then check to see if the issue has been resolved prior to resubmitting rostering data.
Posted Jul 25, 2024 - 12:30 EDT
This incident affected: Realize, Realize Reader, EasyBridge, and SuccessMaker.