Momentum Assessment Access Issue

Incident Report for Savvas System Health

Resolved

This incident has been resolved.
Posted Sep 09, 2025 - 18:35 EDT

Investigating

Students may experience a white screen when accessing Momentum Assessments. Additionally, some teachers have reported they are not able to see Momentum assessments within their Realize programs. Our team is reviewing this issue and will update here when it is resolved.
Posted Sep 09, 2025 - 12:33 EDT
This incident affected: Realize.