Savvas Realize login issue

Incident Report for Savvas System Health

Resolved

This incident has been resolved.
Posted Jan 23, 2026 - 13:41 EST

Investigating

Some users are reporting issues with logging into Realize. Our team is investigating the issue and will provide an update as soon as possible.
Posted Jan 23, 2026 - 12:59 EST
This incident affected: Realize.