Realize enVision Math Assignment Issue

Incident Report for Savvas System Health

Resolved

This incident has been resolved.
Posted May 15, 2023 - 10:35 EDT

Identified

Some enVision Mathematics teachers are reporting an error message when trying to assign content to students. Our team has identified the root cause for the issue and we are working to correct it as quickly as possible.
Posted May 12, 2023 - 11:36 EDT
This incident affected: Realize.