Login Issues

Incident Report for Savvas System Health

Resolved

This incident has been resolved.
Posted Jun 08, 2026 - 09:46 EDT

Update

Reports are now running as expected.
Posted Jun 08, 2026 - 09:42 EDT

Update

The issue is resolved.
Posted Jun 08, 2026 - 09:42 EDT

Investigating

We are aware and actively working to resolve issues with the Realize log in, Assessment Mastery Report, and Realize Admin Reports.
Posted Jun 08, 2026 - 08:56 EDT
This incident affected: Realize and Realize Reports.