Realize Assessment Access Issue
Incident Report for Savvas System Health
Resolved
This incident has been resolved.
Posted Nov 21, 2022 - 11:10 EST
Update
We are continuing to work on a fix for this issue.
Posted Nov 21, 2022 - 10:19 EST
Identified
Our team has identified and is actively working on an issue that is slowing down Realize assessments.
Posted Nov 21, 2022 - 10:19 EST
This incident affected: Realize.