My Library Shared with me tab error

Incident Report for Savvas System Health

Resolved

This incident has been resolved.
Posted Sep 23, 2026 - 23:55 EDT

Investigating

The issue reported earlier with My Library not loading has been resolved, however we are still investigating a concern with the ‘Shared with me’ tab. There is a workaround to get to the content that has been shared until the issue can be resolved.

If receiving the error: “Sorry, something went wrong. Please come back later.”

Then paste this specific Savvas Realize url in the browser address bar: https://www.savvasrealize.com/dashboard/myLibrary/sharedWithMe?locale=en

This will allow the user to resume all activity during their session.
Posted Sep 23, 2026 - 19:53 EDT
This incident affected: Realize.